Функция «Если» в Экселе: основные особенности и примеры

Эксель богат полезными настройками и функциями, к одной из таких можно отнести функцию «Если», примеры использования которой мы сейчас и рассмотрим.

Создание формулы с условием в Excel  с помощью «Если»

Итак, из чего состоит функция Если?

=ЕСЛИ(A1>3;A1*3;A1*4)

  1. Условие (A1>3)
  2. Действие, которое нужно выполнить в случае выполнения условия (A1*3)
  3. Действие, которое нужно выполнить в случае невыполнения условия (A1*4).

Все очень просто, направо пойдешь — коня потеряешь, налево пойдешь — голову потеряешь). Основная задача функции — проверять ячейку на выполнение условия и в зависимости от этого выбирать нужное действие.

В условиях можно использовать следующие знаки:

= Равно

> Больше

< Меньше

>= Больше или равно

<= Меньше или равно

<> Не равно

Функция Если в Excel. Примеры использования

Пример №1

Вы — староста группы и Ваша задача — определить, получат ли студенты Вашей группы стипендию на основании их среднего балла.

Исходные данные

  • средний балл каждого
  • условие начисления стипендии (средний балл больше или равен семи баллам)

Как строим формулу? Если (средний балл >=7 ; начисляем 500 гривен ; начисляем 0 гривен)

В экселе это будет выглядеть так: =ЕСЛИ(В1>=7;500;0)

Функция если в excel примеры

Пример №2

Стипендию получают только учащиеся на бюджете. Как построить формулу Если в Экселе, если присутствует несколько условий?

Добавляем столбец «Бюджет», и проставляем 0 и 1. 0 для контрактников и 1 для бюджетников.

В формуле нашей изменится условие, в его качестве нужно указать программе, что для начисления стипендии нам нужно учитывать и средний балл, и то, что студент — бюджетник.

Как это записать? =ЕСЛИ(И(бюджет = 1);(средний балл больше 7); 500 ; 0)

И в Экселе эта запись будет выглядеть так: =ЕСЛИ(И((B2>=7;C2=1);500;0)

Точно так же можно испольовать предлог ИЛИ, если Вам необходимо выполнение всего лишь одного из условий задачи. Причем этих условий может быть несколько.

функция если в excel примеры

Пример №3. Если в Excel несколько условий.

У нас есть обычная стипендия (500), и повышенная (например, 1000) — для отличников!

Поэтому нам нужно дополнительное условие, проверять, что средний балл не только выше 7ми, но еще и выше 10ти баллов.

Как это записать? =ЕСЛИ(средний балл меньше 7; стипендии нет 🙁 ; если (средний балл больше 10; стипендия = 1000 (условие выполнилось) ; стипендия = 500 (условие не выполнилось))

ЕСЛИ(B2<7;0;ЕСЛИ(B2>=10;1000;500))

Теперь наша ячейка со средним баллом проходит тройную проверку и мы снова получаем сумму начисления стипендии.

Помните, что количество открытых скобок в формулах должно совпадать с количеством закрытых, иначе получите ошибку.

excel если несколько условий

Если у Вас остались вопросы, задавайте их в комментариях:)

Образование и Наука каталог сайтов компаний и фирм Украины — бесплатный каталог фирм, предприятий и интернет ресурсов Украины. Добавить сайт в каталог Уроки и тесты, Образование и Наука.

 


1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5,00 out of 5)
Загрузка...

Комментарии:

Комментарии

  1. Виталий

    Ответить

    • teacher

      Ответить

  2. Алексей

    Ответить

    • teacher

      Ответить

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Яндекс.Метрика Украинский портАл